+ Reply to Thread
Page 7 of 7 FirstFirst ... 5 6 7
Results 151 to 171 of 171

Thread: 408 And A 5-Speed - My Dream Build -

  1. #151


    JDreamR/T's Avatar
    I gots to have mo'par-ts!

    Status
    Offline
    Join Date
    Oct 2009
    Location
    Long Island, NY
    Posts
    1,113

    Default

    Quote Originally Posted by arro222 View Post
    JDream what's that engine cooling fan you're using? Did it come w a shroud or you make that?
    Fabbed it myself, it's the 99 Jeep GC fan powered by a Dakota Digital PAC-2750 controller.

    Quote Originally Posted by 98Dak408 View Post
    Lumpy cam. I thought the vacuum might be a little higher, but even so, you may need to add a vacuum motor to your brake system. I am planning on doing that to mine when I have the time.
    Yeah I may also have to do that. Might try adding a larger reservoir and make sure the check valve is in good order.
    1999 R/T CC Flame Red
    //SHAKER// 408 Forged // TKO600 5spd // Spintech-Mids // FRP Tuned //

  2. #152

    Default

    Quote Originally Posted by JDreamR/T View Post
    Fabbed it myself, it's the 99 Jeep GC fan powered by a Dakota Digital PAC-2750 controller.

    Nice job. Is that the only electric fan cooling the engine?

  3. #153


    JDreamR/T's Avatar
    I gots to have mo'par-ts!

    Status
    Offline
    Join Date
    Oct 2009
    Location
    Long Island, NY
    Posts
    1,113

    Default

    Quote Originally Posted by arro222 View Post
    Nice job. Is that the only electric fan cooling the engine?
    Thanks, yes that's the sole cooling fan it works great throws a good amount of air
    1999 R/T CC Flame Red
    //SHAKER// 408 Forged // TKO600 5spd // Spintech-Mids // FRP Tuned //

  4. #154

    Default

    Quote Originally Posted by 98Dak408 View Post
    Lumpy cam. I thought the vacuum might be a little higher, but even so, you may need to add a vacuum motor to your brake system. I am planning on doing that to mine when I have the time.
    Ever considered hydroboost? I would be in line for a kit. Would give Hemi swap guys lots of room and no worries on vacuum for the big lumpy cam guys..
    Mike Williams
    #001

    98 DA RC GrapeJuice
    99 BLK CC (Buy Back)
    00 BLK RC ProCharged -Hotchkis - on and on (Sold)
    01 AF CC (Leased - Turned in)

  5. #155
    kota360's Avatar
    Senior Member

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Hamilton, On., Ca.
    Posts
    884

    Default

    When you say you have 15lbs at idle, is that with engine and oil up to operating temp?
    When my truck is hot and oil is not after a good run down the highway I have 22-23 lbs at idle,
    That's on an Auto Meter mech oil pres. gauge, 10w-30 weight oil also.
    I would say 15 lbs is on the low side still.
    My engine guy always wants to see 20 lbs and above at idle with everything hot.
    Edelbrock Magnum heads, Harland-Sharp 1:6 RR, Jomar Performance Ultra-Lite Stud Girdle, SoutheastPerformance Sheet Metal Valve Covers, Custom Hyd Roller from Reed Cams, Mopar M-1 2 Brl Intake, Hughes Stage 1 TB, JBA SS Headers, Jacobs Electronics Pro Street Ignition System and Wires, MBRP 'Cuda Style Exhaust, Western Chassis 2" drop front and rear, Edelbrock IAS Shocks, Terry DeLong Pro-Glass Shaker Hood

  6. #156


    JDreamR/T's Avatar
    I gots to have mo'par-ts!

    Status
    Offline
    Join Date
    Oct 2009
    Location
    Long Island, NY
    Posts
    1,113

    Default

    Quote Originally Posted by kota360 View Post
    When you say you have 15lbs at idle, is that with engine and oil up to operating temp?
    When my truck is hot and oil is not after a good run down the highway I have 22-23 lbs at idle,
    That's on an Auto Meter mech oil pres. gauge, 10w-30 weight oil also.
    I would say 15 lbs is on the low side still.
    My engine guy always wants to see 20 lbs and above at idle with everything hot.
    I'm not too concerned of that figure it was showing 15psi at a pretty hot temp (engine coolant @ 200-210°). At the 180° temp its around 20 pounds or better. Also the oil bumps right up in pressure 40-60 when revved up a bit.
    1999 R/T CC Flame Red
    //SHAKER// 408 Forged // TKO600 5spd // Spintech-Mids // FRP Tuned //

  7. #157
    408 club member

    Status
    Offline
    Join Date
    Jan 2008
    Location
    washington
    Posts
    102

    Default

    Glad it's looking good!!! Sounds like it's finally coming together👍👍👍

    VENOM
    1999 408 cc
    best time so far 11.70 @ 116

  8. #158


    99dart's Avatar
    Senior Member

    Status
    Offline
    Join Date
    Feb 2008
    Location
    Washington...the hot side!
    Posts
    3,817

    Default

    Quote Originally Posted by JDreamR/T View Post
    Got it back up and running yesterday, oil looks perfect!!



    Got 15 pounds at idle now, much better!
    Totally kewl! Glad you got it back together and the issue is gone!
    99 DA CC R/T
    13.97@100 w/modded kegger & ported TB
    12.96 @103 new 365 C.I (guessatune
    http://imgur.com/a/lOVuZ

  9. #159

    Default

    15 lbs of oil pressure at idle is fine if idle isn't more than 1000 rpm.
    1941 Dodge 1/2 ton, 493 twin turbo, EFI, 727, 4 wheel disc brakes, custom triangulated 4 link, DANA 60, Gleason Torsen diff,

    2002 Dakota R/T RC, PX8, PPH Headers, MBRP exhaust, K&N FIPK, Hotchkis TVS, 20" R/T chrome rims, BFG G-Force T/A KDW 275/35 ZR20 tires, Kenwood head unit, Kenwood speakers, RF amp, 8" RF Punch Z subs

  10. #160


    JDreamR/T's Avatar
    I gots to have mo'par-ts!

    Status
    Offline
    Join Date
    Oct 2009
    Location
    Long Island, NY
    Posts
    1,113

    Default

    Thanks guys, got the reggie & plates in the mail and took the truck out on the road today!!

    1999 R/T CC Flame Red
    //SHAKER// 408 Forged // TKO600 5spd // Spintech-Mids // FRP Tuned //

  11. #161


    JDreamR/T's Avatar
    I gots to have mo'par-ts!

    Status
    Offline
    Join Date
    Oct 2009
    Location
    Long Island, NY
    Posts
    1,113

    Default

    Ryan still needs to clean up the tune, it bogs bad (goes very rich) quickly under moderate throttle. So far I haven't shifted past 3k and no more than ~1/2" throttle, even still it goes!! Clutch action feels pretty good and shifts clean!

    Things left to do
    1. Set fuel sync calibration
    2. Datalog
    3. Exhaust shop because too fumey w/ dumped exhaust
    4. wire up line lock
    5. get tune from FRP
    6. Test Line Lock
    7. Buy Tires!
    1999 R/T CC Flame Red
    //SHAKER// 408 Forged // TKO600 5spd // Spintech-Mids // FRP Tuned //

  12. #162

    98Dak408's Avatar
    Supporting Vendor

    Status
    Offline
    Join Date
    Jan 2009
    Location
    Detroit Area, Michigan
    Posts
    2,606

    Default

    Sounds good. This helps inspire me to get my truck running again. LOL
    I've spent most of my money on women, booze, and my truck. The rest of the money was wasted!

    Smartphones are a menace to society and are creating a zombie apocalypse!

    If you don't like me on the phone get off the road!

    If you are not passing, GET OUT OF THE FAST LANE!


  13. #163
    Senior Member

    Status
    Offline
    Join Date
    Mar 2009
    Location
    wapato, wa
    Posts
    6,756

    Default

    That does sound good ! You and me both Richard !

  14. #164

    98Dak408's Avatar
    Supporting Vendor

    Status
    Offline
    Join Date
    Jan 2009
    Location
    Detroit Area, Michigan
    Posts
    2,606

    Default

    Took apart the timing set and it revealed I indeed was missing the oil gallery plugs. All fixed up now thanks again to Pat and Lloyd!
    I checked a block that came back from the machine shop, and it is missing the two front oil galley plugs as well. Where did you find those plugs sold individually? Or, did you have to take them from a complete freeze plug kit?
    I've spent most of my money on women, booze, and my truck. The rest of the money was wasted!

    Smartphones are a menace to society and are creating a zombie apocalypse!

    If you don't like me on the phone get off the road!

    If you are not passing, GET OUT OF THE FAST LANE!


  15. #165
    nitroram33's Avatar
    CAUSEDODGEPATTERNBALDNESS

    Status
    Offline
    Join Date
    Jul 2012
    Location
    Robbinsville, NC
    Posts
    786

    Default

    I'm pretty sure I have a freeze kit laying in my floor that I don't need anymore if you need it lol, I'll never use it. This one:

    https://www.rockauto.com/en/moreinfo...1314443&jsn=13

  16. #166


    JDreamR/T's Avatar
    I gots to have mo'par-ts!

    Status
    Offline
    Join Date
    Oct 2009
    Location
    Long Island, NY
    Posts
    1,113

    Default

    Quote Originally Posted by 98Dak408 View Post
    I checked a block that came back from the machine shop, and it is missing the two front oil galley plugs as well. Where did you find those plugs sold individually? Or, did you have to take them from a complete freeze plug kit?
    Richard, yea I had them in the enginepro core plug kit I got from Rock Auto.
    1999 R/T CC Flame Red
    //SHAKER// 408 Forged // TKO600 5spd // Spintech-Mids // FRP Tuned //

  17. #167

    98Dak408's Avatar
    Supporting Vendor

    Status
    Offline
    Join Date
    Jan 2009
    Location
    Detroit Area, Michigan
    Posts
    2,606

    Default

    I'm pretty sure I have a freeze kit laying in my floor that I don't need anymore if you need it lol, I'll never use it. This one:

    https://www.rockauto.com/en/moreinfo...1314443&jsn=13
    Is that the shallow, or deep plug kit?
    I've spent most of my money on women, booze, and my truck. The rest of the money was wasted!

    Smartphones are a menace to society and are creating a zombie apocalypse!

    If you don't like me on the phone get off the road!

    If you are not passing, GET OUT OF THE FAST LANE!


  18. #168
    nitroram33's Avatar
    CAUSEDODGEPATTERNBALDNESS

    Status
    Offline
    Join Date
    Jul 2012
    Location
    Robbinsville, NC
    Posts
    786

    Default

    Quote Originally Posted by 98Dak408 View Post
    Is that the shallow, or deep plug kit?

    No idea at this point, I assume they're just standard plugs:

    https://www.summitracing.com/parts/slp-381-8010

    They were only like $12, PM me an address and I'll just mail them to you lol.

  19. #169

    Default

    Quote Originally Posted by NWRT360 View Post
    Glad it's looking good!!! Sounds like it's finally coming together������
    Pretty good for a fat ass cc. I also have a fa cc. How'd you get yours to 11.7? Boost?

  20. #170

    98Dak408's Avatar
    Supporting Vendor

    Status
    Offline
    Join Date
    Jan 2009
    Location
    Detroit Area, Michigan
    Posts
    2,606

    Default

    No idea at this point, I assume they're just standard plugs:

    https://www.summitracing.com/parts/slp-381-8010

    They were only like $12, PM me an address and I'll just mail them to you lol.
    Thanks Jim! Much appreciated!
    I've spent most of my money on women, booze, and my truck. The rest of the money was wasted!

    Smartphones are a menace to society and are creating a zombie apocalypse!

    If you don't like me on the phone get off the road!

    If you are not passing, GET OUT OF THE FAST LANE!


  21. #171
    nitroram33's Avatar
    CAUSEDODGEPATTERNBALDNESS

    Status
    Offline
    Join Date
    Jul 2012
    Location
    Robbinsville, NC
    Posts
    786

    Default


+ Reply to Thread
Page 7 of 7 FirstFirst ... 5 6 7

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •