+ Reply to Thread
Results 1 to 7 of 7

Thread: Ford 39lb injectors

  1. #1

    Default Ford 39lb injectors

    Hi guys just throwing this out to see some ideas. Just got my 408 fired up with the stock injectors but when I put the Ford racing 39lb injectors in it won't start just crank. I do have a tune loaded in to accommodate for the 39's. I guess I would be looking on advice on how to test the injectors.... I did purch8them used but we're supposedly working when upgraded to new ones......"damn ford parts"

  2. #2
    Senior Member

    Status
    Offline
    Join Date
    Mar 2009
    Location
    wapato, wa
    Posts
    6,437

    Default

    Why 39s? Boosted ?

  3. #3

    Default

    Rail pressure? Plugs wet?
    Mike Williams
    #001

    98 DA RC (soon to be transported to MI)
    99 BLK CC (Buy Back)
    00 BLK RC ProCharged -Hotchkis - on and on (Sold)
    01 AF CC (Leased - Turned in)

  4. #4



    99dart's Avatar
    DRTC Member

    Status
    Offline
    Join Date
    Feb 2008
    Location
    Washington...the hot side!
    Posts
    3,664

    Default

    What they said^^^
    99 DA CC R/T
    13.97@100 w/modded kegger & ported TB
    12.96 @103 new 365 C.I (guessatune
    http://imgur.com/a/lOVuZ

  5. #5

    Default

    I used a little pair of wires that already had alligator clips on one end. I added some female spade stake-ons to the other side. The spades fit perfect inside the connector on the injector. Clip one alligator clip to the battery and tapped the other clip on the other terminal.You will hear the injector tick if its working. But they could still be dirty AF with a shitty spray. You can clean them by taking a 6" piece of fuel line and hose clamping one on either end. Drill a small hole in the fuel line so you can insert the little straw from the fuel injector cleaner. Spray while tapping the alligator clip.

  6. #6
    niebs's Avatar
    Senior Member

    Status
    Offline
    Join Date
    Jun 2015
    Location
    North DE
    Posts
    1,274

    Default

    How long have you tried after the install? It may take a little bit to get it primed.

  7. #7

    Default

    Not boosted NA 408. Running 39's because that is what FR suggested me to do. I made a home made contraption to make sure injectors weren't clogged and all seem to be just fine. .0280156127 is the number on the injector they were out of an 04 cobra

+ Reply to Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •