+ Reply to Thread
Page 5 of 5 FirstFirst ... 3 4 5
Results 101 to 105 of 105

Thread: Working on my Dakota build

  1. #101


    99dart's Avatar
    Senior Member

    Status
    Offline
    Join Date
    Feb 2008
    Location
    Washington...the hot side!
    Posts
    3,282

    Default

    Feels good, Don't it!


    99 DA CC R/T
    13.97@100 w/modded kegger & ported TB
    12.96 @103 new 365 C.I (guessatune)
    http://s110.photobucket.com/albums/n...t=MVI_1720.mp4

  2. #102

    Default

    Quote Originally Posted by 99dart View Post
    Feels good, Don't it!
    Yes, yes it does!

    Canadian Tire Performance Parts
    Instagram moderator for dakota_rt_club

  3. #103

    Default

    Went to the first car meet cruise in we have every Thursday evening when the weather is nice.
    [IMG][/IMG]

    Canadian Tire Performance Parts
    Instagram moderator for dakota_rt_club

  4. #104

    Default

    Running Ryan's base tune still and the engine runs excellent, it's hard to believe it runs so well and only about to get better with some fine tuning. I'll be doing some data logging when I get back in about two weeks. I'll be installing the SS JBA replacement "Y" pipe with two new NTK O2 sensors and the additional bung for the wideband sensor.

    I'm approaching 1000kms so far on the rebuild and I got on it a bit once it was up to temp and yeah she's got some f'n power. Also sounds wicked with some more pronounced pop and bang than it did before, it's that good performance engine sound you want to hear.

    Added a 1" aluminum spacer to the K&N air filter. Added Moroso plug wire stand offs and made up a new rubber flap for the rad as the old one kinda fell apart.

    [IMG]
    [/IMG]
    [IMG][/IMG]
    [IMG][/IMG]
    [IMG][/IMG]
    [IMG][/IMG]
    [IMG][/IMG]

    Canadian Tire Performance Parts
    Instagram moderator for dakota_rt_club

  5. #105
    mopar5.9's Avatar
    Senior Member

    Status
    Offline
    Join Date
    Feb 2016
    Location
    Amsterdam
    Posts
    118

    Default

    I also have the jba ss y- pipe and i think it really sucks. from day one i have fitment problems . it is to close to the transmission pan and the fitting that goes to the cat also sucks . the fitting on both my cats the oem and the direct replacement magnaflow give problems with the jba y pipe . i also have fitment problems with my gibson ss ceramic headers with the y pipe but you have jba headers so it might fit good on your headers . the jba is not a direct replacement pipe like they say it is . BTW very nice truck

+ Reply to Thread
Page 5 of 5 FirstFirst ... 3 4 5

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •